System Requirements

operating system

Windows 10
Windows 8.1+
Windows 7 with SP1
macOS 10.6+
Google Chrome OS 26+

Browser Requirements

Google Chrome 46+
Apple Safari 8.0+
Microsoft Internet Explorer 11+
Microsoft Edge
Mozilla Firefox 42+

Plugins and Settings

The following may be required to use our courses:
JavaScript enabled
Cookies enabled
Flash enabled
Java installed

Additional Requirements

Adobe Reader 6.0 or higher
Adobe Flash Player 9.0.115 or higher
World Languages require speakers and microphone
Elementary courses require speakers and microphone
PDF Editing program for assignments 

You must have an internet connection and it is highly recommended that a broadband connection be used.
See Software Resources page for any recommendations on software/apps to be used in the courses.
Many of these options are free, you are not required to purchase any software to complete coursework with JEDI.
If you have any questions or need help with system requirements, please contact the HELP DESK

wifi